Jump to content
superfuture

OLD supertalk upgraded 3.3.3

Recommended Posts

in case any of you were wondering what i have had to deal with for the past 4 days this latest email should give you an idea...

++++++++++++++

hello,

we've reviewed your request and unfortunately, it is going to require further investigation. i've escalated your ticket, and it will be addressed as quickly as possible. because of the advanced nature of your request, please note that it may take longer than usual to fully address your concern. i apologize for this delay and appreciate your patience.

many thanks,

Share this post


Link to post
Share on other sites

Every time I go on the site with my phone, I lose my forum theme preference (goes from my usually uppercase to regular). Also, I have to click 'full site' at the bottom of the page as it doesn't remember my preference to always view in the full site view as opposed to the mobile version.

Share this post


Link to post
Share on other sites

and .............................while we are patiently waiting............................

summary of issues i can see on function side [if anyone wants to update or clarify pls do so.] :

+++++

1. speed.

--> its erratic. sometime superfast then a crawl. we're seeing server loads from 1.5 -- 26...yet it should be around 3-5.

the speed issue is probably causing most of the other issues as it is not allowing pages/ajax to load faster enough and so these queries are timing out...

ie...

IMPROVED

+++++

1. reputation.

--> not able to rep right now -- [assume speed related]

--> cannot hover over rep to see who has repped. [not sure if this is a bug or intended? i hope the former.]

FIXED

+++++

2. first unread post

- no option to go the first unread post in a thread.

--> [seems a skin issue i think - as seems ok on superfuture theme but not on supercase theme]

--> "can only click the whole thread (= going to the first post of the thread) or can only check the latest post. but then i have to scroll back to the first unread post"

+++++

3. search content

--> new sphinx search - not finding content in 'forums' - only 'members'

--> users content - not finding any content.

FIXED

still an issue with search not picking up on recently posts

+++++

4. tags

--> tags topic links at bottom of topic pages is no longer showing.

FIXED

+++++

5. posting issues

--> problems with quick reply - unless i hit the "more reply options" button [assume speed related]

--> can't edit posts, or post pictures currently. [assume speed related]

FIXED

+++++

6. theme issues -

"most of my problems may be related with me using the upper case theme."

--> switching from suppercase to superfuture theme fixes the rep problem.

--> (but can't see the rep history of a post

--> can't leave rep on uppercase

FIXED

+++++

7. theme issues -

--> i lose my forum theme preference (goes from my usually uppercase to regular). also, i have to click 'full site' at the bottom of the page as it doesn't remember my preference to always view in the full site view as opposed to the mobile version.

+++++

Share this post


Link to post
Share on other sites

much, much faster now. seems like 80-90% normal speed, but that may just be my connection

edit: wait nvm, still super slow

Edited by saffronrevolution

Share this post


Link to post
Share on other sites

status update...

++++++++++++++++++++

right now the speed issue has all the tech experts at the software company still guessing what the problem is. they have re-escalated it one notch further up to the original developers as this bug seems to be something they have never seen.

the new 3.3 update has new archiving tools specifically designed for boards with massive topic posts like supertalk has [such as waywt - that have over 80,000 replies], and the possibility that this new code is causing the issues is one focus of investigation.

whether this is also causing all the other functional issues is undetermined at this point.

in summary, so far the major recommendations to solve the issue have been:

1. we install sphinx search [which we did over the weekend]... but this made no difference and isn't working anyway...

2. we archive all the 'large' topics [whether this is '500+' or '50,000+' hasn't been clarified]... but we explained to them that with 2,500,000+ posts that could take 'months' and with no guarantees at this point that it that would actually make any difference at all to the immediate usability issues. we will make use of the archiving system, but only once we know the site is working properly or if there is a high probability that this will simultaneously and miraculously cure all the other issues.

anyway, we have been patiently awaiting a further update for about 15 hours now.

as you can imagine the support ticket is already monumental...

i'm off to dean & deluca for a caramel macchiato and almond croissant.

laterz

Share this post


Link to post
Share on other sites

yes.

you will get your content back. it hasn't gone anywhere. it's still on the database... it's just that the queries to the database aren't returning results...

Will we get our content back? can anyone use the search option yet?

Share this post


Link to post
Share on other sites

The link to view new posts in a thread is missing. Makes it very hard to skip to new posts. DO NOT WANT.

Share this post


Link to post
Share on other sites

Its been like 2 weeks and things are still almost as bad; no content, no search and very slow loading. Sort it out.

Share this post


Link to post
Share on other sites

BTW --> THIS IS SUPPOSED TO BE AN ANNOUNCEMENT BUT THAT TOOL AIN'T WORKING. GREAT.

dear sufustalkers.

if you have been using the site since june 14, or following this thread you will no doubt be aware of the insanely irritating performance and shitty functionality issues we have been having since this supposedly straightforward upgrade turned slightly watermellon.

as i have said many times before - getting anything FIXED is a painfully slow process when going through tech ticket systems and there are over 100 messages so far between superfuture and software developers. often i am waiting up to 24 hours for a reply not including THEIR weekends. so if this could have been sorted out any faster it would have been...

1 // erratic speed

software developers have traced the issue to new code that changes the way MySQL interacts with REALLY LARGE topics [like waywt] that have 80,000+ posts and 14 million+ pageviews. the upgrade allows us to now archive these large topics but ironically the new code has slowed the site before we have got to do the archiving. we currently have 10 topics that are considered REALLY LARGE and beyond the capacity of MySQL. we have been recommended to cut size of threads to 15,000 and page views to 1,000,000. there are currently 137,420 topics on supertalk.

quote:

With topics in the 80,000 replies mark, you have to realise that to fetch the information to that topic, MySQL has to loop through 80,000 rows in the database, and then offset those results to get the last page, and then limit that resultset to 10, and it's doing this on every single pageload of that topic. So if 10 members are reading that topic, that's 80,000 * 10, that's 800,000 rows MySQL has to loop through simultaneously.

Now MySQL is pretty fast when it comes to this sort of thing, but it's not designed to handle this sort of stress. That's just from your ONE 80,000 posts topic, meanwhile people re doing things on your forum all the time like making new posts, making new topics, viewing other BIG topics, and before sphinx was installed, Searching. etc.

so we have to either archive these large topics or [preferably] split them into years... i.e. 'waywt... 2011', 'waywt... 2012' etc. we will also archive many older posts [probably those that have not had posts for 3-5 years]. the aim is to get the server load back down and get speed optimized.

archiving means they will be put into a read-only state. no rep, no replying, reporting or quoting.

splitting them into years means they will still be in an active state as separate topics.

2 // 'missing' content

developers have also have tracked down the issues with search, which is also causing contents not to appear in your profiles. hopefully this will also be fixed in the next few days. content should then reappear, and new search and tags should function normally.

FIXED

3 // other functionality issues

we are tracking the other known issues in this thread. most are likely related to the above 2 core issues.

--> with a bit of luck this is all going to sort itself out starting from monday - USA time.

!!

Share this post


Link to post
Share on other sites

what's supposed to be upgraded?

Share this post


Link to post
Share on other sites

what's supposed to be upgraded?

this, i haven't noticed anything running better since the "upgrade"

Share this post


Link to post
Share on other sites

The main page is still quite slow to load…

edit: actually as I typed this, it just got really better.

Edited by Dropt

Share this post


Link to post
Share on other sites

they are working on getting search back ATM. though server load is pretty high as a lot of traffic today so expect all sorts of unexpectedness.

Share this post


Link to post
Share on other sites

its working!

nm/reply still slow and cant see reps

Edited by mr.invincible

Share this post


Link to post
Share on other sites

yeh its working but still erratic and slow... and still a few cleanup items. [we should be able to see who left reps in posts etc - these are skin issues - as we know they are there on the default templates]

after 2 weeks of troubleshooting this software upgrade and looking at sphinx/archiving etc etc...tweaks to the configs. etc etc... techs are now of opinion that the issue is with capacity of servers. it seems the upgrade is just requiring the servers to do that much more than they were previously coping with and this has tipped them beyond ability. the problem is no-one really knows for certain and so everything is speculation until proven fixed... there are probably about 10 different tech people have weighed in on this issue over the past few weeks and everyone seems to have had different opinions.

so now waiting on proposals on best options from a completely new hosting company who has been highly recommended...

Share this post


Link to post
Share on other sites

Speed is a little better

Still takes a lifetime to post

Share this post


Link to post
Share on other sites

we are going to switch the database tomorrow to run it on another server to see if that helps. will update exact time once confirmed. probably around midnight EST. maybe 15 minutes of downtime.

btw... the REP COMMENTS should now be viewable... though it seems to freeze the screen on iPads...?

Share this post


Link to post
Share on other sites

and how does one leave a rep comment

Share this post


Link to post
Share on other sites

sorry...

meant the 'view who has given rep' when you hover/click on the rep score on posts.

as for rep comments - in the last few weeks we have found a developer who thinks it is possible to get our old rep comments from 4.0 working on supertalk 5.0... so that is in the tech pipeline. but right now just trying to get the site working properly,

FYI.. we are looking at some downtime around 12am saturday night new york time - as techs try a server database switch.

Share this post


Link to post
Share on other sites

made two posts last night and they and the threads they were in seem to have disappeared

Share this post


Link to post
Share on other sites

what time?

hmm. probably floating around in the internetz. if it was around 1AM USA EASTERN TIME i am thinking they might have got lost in the server switchover?

made two posts last night and they and the threads they were in seem to have disappeared

Share this post


Link to post
Share on other sites

yeah it was around that time

Share this post


Link to post
Share on other sites

Things are definitely a lot better than the last few weeks.

One issue I've noticed is that a lot of posts aren't showing in via search or via 'my content' ...

Just one example, this was just posted in classifieds, http://supertalk.superfuture.com/index.php?/topic/138579-fs-marsell-wrap-around-lace-derbies-fits-41-415/

but I can't find the post via search using any of the words in the title?

Share this post


Link to post
Share on other sites

i can rep again!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Luisa via Roma (US)
    Brand - 125 x 125